
UNBOX TINKERING

ACTIVITY BOOK

ATL TEACHER TRAINING



1



2

Dr. Chintan Vaishnav

Mission Director
Atal Innovation Mission
NITI Aayog



3

Tejaswini Rajwade

CFO
IBM India 

Message
At IBM, we constantly seek new opportunities to harness the power of technological 

innovation for social impact. Our partnership with the Atal Tinkering Lab (ATL) 

initiative in India is a result of our firm commitment to this cause. Technology is 

all around us, and is dramatically reshaping our world. It is vitally important to 

prepare the next generation to thrive and excel in this challenging environment. 

The Atal Tinkering Lab (ATL) initiative introduces Indian school children to disruptive 

technologies at an age when their minds are most receptive to new influences.  

IBM has been following a comprehensive strategy to support and benefit the key 

stakeholders of the ATL initiative: schools, teachers and students. It is necessary to 

build the capacities of educators, so that they can imbue the pedagogical content 

and strategies with the knowledge, skills, and mindset to inspire technological 

innovation. ‘Unbox Tinkering’, the ATL Teachers’ Training Program, is a welcome 

step in this direction. It provides teachers with an understanding of the core 

principles and cutting-edge technological tools to facilitate the ATL program 

effectively for their students. 

We hope that the publication of the Unbox Tinkering Activity Book will be an 

aid to teachers in navigating through foundational technological concepts and 

implementing these through the ATL program in their respective schools. To 

prepare the students for a future we cannot yet see, and train them for careers 

that have not yet been invented, education must go down pathways that have 

not yet been explored. With the Unbox Tinkering Activity Book, we wish all the 

ATL teachers to have an enjoyable and memorable journey of exploring new ideas 

and approaches.

Tejaswini Rajwade
CFO, IBM India 
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Preface
Our former President late Dr. APJ Abdul Kalam Ji had said “Teachers are the backbone of any country, the pillar upon 
which all aspirations are converted into realities”. Atal Innovation Mission (AIM) has been on a journey to realize the 
aspirational vision of the ‘New India’ through the help of these foundational pillars of our country – the teachers – 
through its Atal Tinkering Labs initiative.

AIM is a flagship initiative of NITI Aayog to promote innovation and entrepreneurship across the length and breadth of 
the country. At the school level, AIM has been setting up Atal Tinkering Labs (ATL) in schools across the country. ATLs 
are makerspaces which give an opportunity to young students to turn their creative ideas into working prototypes by 
providing access to the latest technological equipment like 3D Printers, Arduino Boards, Raspberry Pi, DIY kits etc. This 
initiative is also honing young innovators on crucial 21st century skills including Critical Thinking, Social and Cross-
Cultural Collaboration, Ethical Leadership, Design Thinking etc.

Tinkering is a relatively new concept in the Indian education ecosystem, so it requires training and handholding 
facilitated by a sustained engagement with subject experts, at least in the initial stages of the ATL setup. For this, AIM 
keeps organizing regular ‘Unbox Tinkering’ – Atal Tinkering Labs Teachers’ Trainings across India, in association with 
its partners from the industry and academia, where ATL schoolteachers are trained on the philosophy of ATL and on 
the latest technology tools. The training programs include a series of discussion and simulation sessions which allow 
interactive and open learning and exchange of new ideas. The training programs are organized through classroom and 
virtual sessions along with self-learning modules to enable familiarization of the ATL facility to the teachers.

The Unbox Tinkering - Teacher Training Activity Book is an attempt to take the learning forward from the training 
program to the student classrooms in the ATL schools. The book will help the teachers to apply their learnings from the 
training through source references, activities, workbook exercises, test your knowledge quizzes etc. The book will also 
serve as a concrete framework to conduct similar trainings for the students. It is a supplement to the content already 
available on AIM website in the form of various learning modules and resources. 

I would like to thank all our partners and trainers for their time and effort in helping the teachers get the most value 
from the ATL initiative by conducting the training workshops across the country. It is because of the teachers’ dedication 
and support that the students are empowered to Explore, Tinker, and Innovate.

I take this opportunity to thank NITI Aayog Vice-Chairman Dr. Rajiv Kumar, CEO Mr. Amitabh Kant, and Mission Director 
Dr. Chintan Vaishnav, AIM, for their leadership and continuous support towards making ATL a national movement in 
the country.

My special acknowledgment to IBM and its partners – Learning Links Foundation, SRF Foundation, Vikram A Sarabhai 
Community Science Centre, Chrysalis Foundation for providing invaluable support in implementing the ATL Teacher 
Training program across the length and breadth of the country.

I would also like to thank the core ATL team members Ms. Swati Rao, Mr. Prateek Deshmukh, Ms. Naba Suroor, Mr. 
Jayant Vig and Ms. Tanvi Mishra for supporting the entire program.  Ms. Vishnu Priya Bijapur and Mr. Ronak Jogeshwar 
have provided invaluable support in leading the Unbox Tinkering Teacher Training program and in editing this book.

I hope this book empowers the teachers in realizing the vision of the Atal Tinkering Labs initiative and help pave the 
way forward for an ‘AatmaNirbhar Bharat’. 

Happy Tinkering 

Ms. Deepali Upadhyay

Program Director

Atal Innovation Mission

NITI Aayog
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ATAL INNOVATION MISSION 
Atal Innovation Mission (AIM) is a flagship initiative of the Government of India, housed at NITI 
Aayog, with a focus to build an innovative and entrepreneurial ecosystem across India, with public-
private partnerships. AIM is envisaged as an umbrella innovation organization that would play an 
instrumental role in alignment of innovation policies between central, state and sectoral ministries, 
by incentivizing the promotion of an ecosystem of innovation and entrepreneurship at various levels 
- higher secondary schools, higher educational and research institutions, and SME/MSME industry, 
corporate, and government ministerial level, by public-private partnership.

The Atal Tinkering Lab (ATL) initiative was launched in 2016, to foster the spirit of innovation and 
curiosity in young minds of India. The ATL program design and implementation follows a plug and play 
approach and includes standard guidelines, curriculum, training tools, standard operating procedures 
(SOP) and is supported by a robust IT system and several partnerships. It enables the creation of a 
culture of innovation and a vibrant collaborative ecosystem within the school community, through 
celebration and recognition of innovative students, teachers, mentors, parents and other stakeholders. 
ATL has also focused on regular monitoring and evaluation to understand the outcomes and impact 
generated by the program and take frequent course-corrective measures to improve on challenging 
areas. The four-pillar implementation framework is illustrated below:

AIM is mandated to establish 10,000 ATLs across the country by FY 2021. As of September 2021, 
close to 9300+ ATLs have already been funded by Atal Innovation Mission.

The major objectives of establishing an ATL include the following:

	y To create workspaces where young minds can learn innovation skills, sculpt ideas through hands-
on activities, work and learn in a flexible environment 

	y To empower our youth with the 21 century skills of creativity, innovation, critical thinking, design 
thinking, social and cross-cultural collaboration, ethical leadership and so on.

	y To help build innovative solutions for India’s unique problems, and thereby support India’s efforts 
to grow as a knowledge economy.
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Atal Tinkering Labs(ATLs): 
With a vision to ‘Cultivate one Million children in India as Neoteric Innovators’, Atal Innovation Mission 
is establishing ATLs in schools across India. The objective of this scheme is to foster curiosity, creativity 
and imagination in young minds; and inculcate skills such as design mindset, computational thinking, 
adaptive learning, physical computing etc.

BACKGROUND 

‘Unbox Tinkering’ – ATL Teachers’ Training Program

ATL is Atal Innovation Mission (AIM), NITI Aayog’s flagship initiative to promote innovation and 
creativity amongst high school students. The Government of India is establishing Atal Tinkering Labs 
in schools which are open innovation workspaces to introduce students to latest technologies of 
3D Printing, IoT, Microelectronics, Robotics, Drones and 21st Century skills of Collaboration, Critical 
Thinking, Design Thinking, Ethical Leadership and so on. Tinkering is a new concept in India, and 
it requires continuous handholding facilitated by a sustained engagement with subject experts. In 
this regard, AIM, NITI Aayog keeps organizing regular ATL teacher training programs in different 
states of India, in association with several partners, where selected school teachers are trained on the 
philosophy of ATL and latest technology tools. The training programs include a series of discussion 
and simulation sessions which allow interactive and open learning and exchange of new ideas.

ATL HANDBOOK 

The ATL Handbook describes the philosophy and the journey of Atal Tinkering Labs whose 
vision is not just to cultivate one million children as neoteric innovators, but also to foster 
the curiosity, creativity, and imagination in young minds.

Unbox Tinkering
Atal Tinkering Labs

Teachers Training Program
Website:

niti.gov.in | aim.gov.in

http://qr.w69b.com/g/manp2sRCo
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ABOUT THIS BOOK 

This application guide will help you understand the content of the Teacher Training Program and 
how to take participants from mere ideas to creating innovative solutions. It will help you apply your 
learning in your classroom. Further it will test your understanding questions which in turn will help 
you carry out the session for your students. The Application Guide and the presentations will give you 
a concrete framework to conduct the workshop, based on the needs of any cohort.

To Learn: The book is a supplement to the content in the presentation. The presentation & Sites 
can be accessed by scanning the QR code on the main page of all the topics. The book will help the 
teachers & students apply their knowledge, enhance their understanding during & after training. 

To Teach: The book can be used along with the PowerPoint presentation/Sites that teacher/trainer 
will be using to take the sessions for his/her students. Teachers/Trainers can take prinouts of the 
worksheets depending on the topic that will be taken up during the session so that the students can 
write and share the experience of their tinkering journey.
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ATL MODULES

AIM along with its partner organizations, keeps creating and sharing modules on 
different technologies. Keep an eye on the ‘ATL Curriculum’ page for all the new 
content! Some of the popular Modules are mentioned below.

ATL AI-Base Module
The ATL AI-Base Module is introduced with the objective that students leverage 
the full potential of the ATL, the latest technologies introduced in the labs and the 
various equipment’s installed there. The students can ideate, create, and thereby 
self-learn unleashing the ‘Student-Maker’ in them on their path to game-changing 
inventions.

ATL Step-Up Module
The ATL AI Step-Up module is a continuum to the ATL AI Base Module where the 
students who have grown an appetite towards the technology can become experts 
of the Artificial Intelligence Technology. This module is a combination of robust 
exercises to engage with participants and make learning AI a ‘Fun’ exercise. The 
hands-on and activity-based approach helps the students hone their skills across 
various aspects of the AI technology.

ATL Drone Module 
The ATL Drone Module was developed to enable the students to explore the world 
of drones and its possibilities, allowing their imaginations to fly high. With the 
Drone module, Sky indeed is the limit for their creativity and innovation. Students 
will be able to connect this module to their academic subjects, especially physics 
and mathematics, and enhance their spatial problem-solving skills.

ATL Space Module 
The ATL Space Module allows student innovators to understand the technologies 
that are used in space to get inspired. The module is a starter’s kit to Space science, 
developed on the philosophy of ‘learning by doing’. Students can build their 
prototypes with the help of introductory information provided in the module.

ATL Game Development Module
Game development helps students develop skills like Creativity, Critical Thinking, 
Storytelling, Visual aesthetics/User Interface Design(UID), Programming, and 
Strategic Thinking. These skills, also known as future skills, are the most sought 
after skills in the workforce of 2030.

http://qr.w69b.com/g/p4mhs9Qys
http://qr.w69b.com/g/lbnk3srPG
http://qr.w69b.com/g/mZEDTU5HO
http://qr.w69b.com/g/p9YQ3VFF6
http://qr.w69b.com/g/uhb9gIDvy
http://qr.w69b.com/g/smhXuG1zi
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UNIT 1
AIM Website Exploration

Topics Covered
	y INTRODUCTION TO AIM WEBSITE

http://qr.w69b.com/g/u5kJkF7RS


2

AIM WEBSITE EXPLORATION
BACKGROUND
With a vision to ‘Cultivate one Million children in India as Neoteric Innovators’, Atal Innovation Mission 
is establishing Atal Tinkering Laboratories (ATLs) in schools across India. The objective of this scheme 
is to foster curiosity, creativity and imagination in young minds; and inculcate skills such as design 
mindset, computational thinking, adaptive learning, physical computing etc.

KEY FEATURES OF ATL 
ATL is a workspace where young minds can give shape to their ideas through hands-on do-it-yourself 
mode; and learn innovation skills. Young children will get a chance to work with tools and equipment 
to understand the concepts of STEM (Science, Technology, Engineering and Math). ATL provides 
educational and learning ‘do-it-yourself’ kits and equipment on – science, electronics, robotics, open-
source microcontroller boards, sensors and 3D printers and computers. To foster inventiveness among 
students, ATL conducts different activities ranging from regional and national level competitions, 
exhibitions, workshops on problem-solving, designing and fabrication of products, lecture series etc. 
at periodic intervals.

Every ATL school has an ATL In-charge appointed by the school to guide the ATL students.

EXPLORE- 
The AIM website is your one-stop source to learn all about Atal Innovation Mission and its 
initiatives. The schools can explore the website & gain information to effectively implement ATL 
Program in their school.

Some of the topics which a school can explore are listed below.

	º Grant in Aid Fund Utilization for ATL Schools

	º ATL Advisory Committee

	º Integrate ATL in School Curriculum

	º ATL Dashboard

	º ATL Query Resolutions System

	º Mentor India Program

	º Atal Incubation Centre 



3

WEBSITE ACTIVITY
TIME: 30 minutes

RESOURCES: Activity sheet from Annexure 1, Laptop with Internet Connectivity.

ACTIVITY:
1.	 Divide the participants into 7 groups.

2.	 Provide the activity sheet(Annexure 1 - Page 109-115 ) to the participants.

3.	 Give all the teams separate topics and ask them to explore the website.

4.	 Allow them to explore their respective topic for 20 minutes.

5.	 Ask the participants to explore other topics if the group has completed their designated topics.

6.	 Ask each team to present what they have learnt from the topic.

Allow other teams to ask questions related to the topics so that they can answer the questions 
provided in the Annexure sheet.

THINGS YOU CAN DO:
Spend some time to explore the other topics in the website to get a clearer idea about the importance 
of the topics related to the ATL.

 
Scribble Space

Use this space to jot down your thoughts
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WELCOME
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UNIT 2
PFMS

Topic Covered
	y INTRODUCTION TO PFMS

http://qr.w69b.com/g/muy51Ao7u
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PUBLIC FINANCIAL MANAGEMENT SYSTEM
INTRODUCTION TO PFMS

ACTIVITY BASED QUESTIONS
1.	 What is the role of “Data Operator(Maker)” and “Data Approver(Checker)” in PFMS?

2.	 Write the steps to map the vendor?

3.	 Why is it mandatory for schools to regularly enter and updated all the expenditure related to ATL 
on their PFMS account?

THINGS YOU CAN DO:
	y Explore the different tabs present in PFMS Portal. 

	y How to generate EAT report in PFMS.

 
Scribble Space

Use this space to jot down your thoughts



7

PFMS
EXPLORATION
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UNIT 3
GeM

Topic Covered
	y INTRODUCTION TO GeM

http://qr.w69b.com/g/lKpBMTADm
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GOVERMENT e-MARKETPLACE
WORKSHEET: GeM

ACTIVITY BASED QUESTIONS
1.	 What is difference between Direct purchase & Bid?

2.	 Write the steps to create a Bid?

3.	 Can we cancel a bid after it has been created?

 THINGS YOU CAN DO:
	y Who can buy/purchase through GeM? 

	y What are the Requirements to utilize the GeM portal?

 
Scribble Space

Use this space to jot down your thoughts
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GeM
QUERIES
RESOLUTION
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UNIT 4
Design Thinking

Topics Covered
	y INTRODUCTION TO DESIGN THINKING

	y DESIGN THINKING TEMPLATE

	y INTELLECTUAL PROPERTY RIGHTS

http://qr.w69b.com/g/s71Nx0cJW
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DESIGN THINKING
TIME: 15 minutes

RESOURCES: Pen and Paper

ACTIVITY:
Step 1: Interview- Pair the group members and start gathering insights on their motivation and needs 
by asking “Why?” and “How?”. At this stage, they need to be curious and avoid making assumptions 
or even jumping to solutions.

Step 2: Dig deeper and reframe the problem.They should discuss and understand each other’s needs 
and interests of how they want a wallet to be. Gather their thoughts and synthesize their learnings 
into goals and wishes. 

Step 3: Ideation! Sketch at least 5 desirable wallets to meet your user needs.

Step 4: Share solutions and gather feedback.

Step 5: Prototype! Using a pen and paper, participants will have to create/draw an ideal wallet of 
their choice for their partner.

 
Drawing Space

What did you learn from the Activity? 
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WORKSHEET: DESIGN THINKING
1.	 Write the steps involved in Design Thinking. 

2.	 Why is Empathy important?

3.	 What should we do during ‘Ideation’?

	� Find the best idea.

	� Generate ideas and solutions.

	� Understanding the problem in detail.

	� Generating alternatives to tests.

4.	 Design thinking is a ----------------

	� Way of thinking about Design.

	� Method and mindset to define, frame, and solve problems.

	� Way to separate “Thinking” from “Making”.

	� Curriculum for teaching non designers design.

 THINGS YOU CAN DO:
	y Try to find a major issue in your society and figure out the solution by applying design thinking.

	y Analyze how things like the table and chair are designed.

	y Read about the Invention of Wheels.

 
Scribble Space

Use this space to jot down your thoughts
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DESIGN THINKING TEMPLATE
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Modified Design
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INTELLECTUAL PROPERTY RIGHTS
TIME: 20 minutes

RESOURCES: Worksheets and Pencil 

ACTIVITY:
	y Circle the inventions among the following.

	y Find the famous trademarks and circle them in the following puzzle ?.

	y Tick True or False	

	y It is right to watch Bajrangi Bhaijaan without paying for it.                                     (True/False) 

	y I like how this story is written. I can copy it to get an “A” grade.                              (True/False) 

	y Everything on the internet is not free for use.                                                          (True/False) 

	y If there is no “©” (the copyright symbol) at the bottom of a  painting or poem.it means that there 
is no copyright in  that painting or poem.                                                                (True/False) 

	y Design one of the following in the box below.t



19

WORKSHEET: INTELLECTUAL PROPERTY 
RIGHTS

THEORY QUESTIONS
1.	 Why is Intellectual Property important to ATLs??

2.	 The following IPR can be filed for how many years..

	y Patents         ____________ Years

	y Trademarks   ____________ Years

	y Copyrights    ____________ Years

	y Design          ____________ Years

THINGS YOU CAN DO:
	y Can you think of some examples of the  various types of Intellectual Property  that we have 

discussed and list them.

 
Scribble Space

Use this space to jot down your thoughts
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CREATING
PROTOTYPE
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UNIT 5
Basics of Electronics

Topics Covered
	y COMPONENTS 
	y CURRENT, VOLTAGE AND RESISTANCE
	y SERIES AND PARALLEL CIRCUITS
	y PAPER CIRCUITS

http://qr.w69b.com/g/qw64OLEUE
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COMPONENTS
 (LED, BATTERY, JUMPER WIRES, CAPACITOR, RESISTOR)

TIME: 10 minutes

RESOURCES: 3V Coin cell, 9V Battery, 3LEDs, Male to male jumper wires, Male to female jumper 
wires, Female to female jumper wires, Capacitors and Resistors.

ACTIVITY:
1.	 Place the components under resources in their designated places on the sheet below

2.	 Denote the +ve and –ve ends of the components wherever applicable.

Coin Cell Battery 9V LED

Male to Male 
Jumper Wire

Male to Female 
Jumper Wire 

Female to Female 
Jumper Wire

Capacitor Resistor
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WORKSHEET: COMPONENTS
THEORY QUESTIONS
1.	 What is the SI unit of a resistor?

2.	 Define the purpose of Jumper Wires. 

3.	 What is the difference between a resistor and a capacitor?

 

THINGS YOU CAN DO:
	y Find out the different types of batteries available and find out the reason behind the codes given 

to the different batteries.

	y Make a battery using a potato.

 
Scribble Space

Use this space to jot down your thoughts
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CURRENT, VOLTAGE & RESISTANCE
TIME: 20 minutes

RESOURCES: For a group of three (Transparent straw, small thermocol balls and water). 

ACTIVITY:
1.	 Take a straw and pour water inside the straw.

2.	 Observe the flow of water.

3.	 Now take some thermocol balls and add it inside the straw.

4.	 Now pour water inside the straw and observe the flow of water.

5.	 Answer the questions below based on your observations.

    

ACTIVITY QUESTIONS
1.	 What happens to the flow of water when you tilt the straw?

2.	 What do you think will happen when you add more thermocol balls?
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WORKSHEET: CURRENT, VOLTAGE & 
RESISTANCE

THEORY QUESTIONS
1.	 What is the direction of flow of electrons?

2.	 What is the difference between AC and DC signals?  

THINGS YOU CAN DO:
	y List 5 appliances at your home which work on AC and five devices which work on DC.

	y Find out why the power supply is cut when the fuse is burnt.

 
Scribble Space

Use this space to jot down your thoughts
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SERIES & PARALLEL CIRCUITS
TIME: 30 minutes

RESOURCES: For a group of 3: 3V Coin cell, 9V Battery, 5 LEDs and 1m single strand wire.  

ACTIVITY:
1.	 Attach the +ve leg of the LED to the +ve terminal of coin cell and –ve leg to the –ve terminal of 

the coin cell.   

2.	 Let’s make two circuits.

3.	 For the first circuit: as shown in the fig. below, take more LEDs and connect the +ve end of all 
LEDs to one wire and the –ve end to another wire and finally connect to the battery and observe.

 

4.	 For the second circuit: as shown in the fig. above, connect the +ve end of the first LED to the 
first wire and its –ve end to the +ve end of the second LED to make a chain of connections. Now, 
connect the –ve terminal of the last LED to the second wire. Finally, connect the first wire to the 
+ve terminal of the coin cell and the second wire to its -ve terminal and observe the changes.    

5.	 Answer the below questions based on your observations.

ACTIVITY QUESTIONS
1.	 What differences did you observe in circuit 1 when compared to circuit 2? 

2.	 What happens when you make a series connection with a 9V battery?
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Scribble Space

Use this space to jot down your thoughts



28

WORKSHEET: SERIES & PARALLEL CIRCUITS
THEORY QUESTIONS
1.	 What remains constant in a series connection?

	� Voltage 

	� Current

	� Resistance

2.	 What is the relation between Current and Voltage in a circuit ?

3.	 Which connection is used to operate more than one device in a household connection?

	� Series Connection 

	� Parallel Connection 

THINGS YOU CAN DO:
	y Try out the activity with other voltage sources. Be careful while using it, for safety measures use 

batteries. 

	y Make a combined circuit with three LEDs in series and three in parallel.

	y Try connecting +ve leg of one LED to the +ve terminal of the battery and +ve leg of the other LED 
to the –ve terminal of the battery while combining both the –ve legs of the two LEDs.

 
Scribble Space

Use this space to jot down your thoughts
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PAPER CIRCUITS
TIME: 30 minutes

RESOURCES: For every participant: Coloured chart paper, 5 LEDs, 1m copper tape, coin cell, sketch 
pens, and pencil.

ACTIVITY:
1.	 Based on the video you watched, make a similar paper card.

2.	 Try to make a circuit having a switch by copper tape.

3.	 Decorate the card.

4.	 Stick the card in the space provided below.
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PAPER
CIRCUIT
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UNIT 6
Computational Thinking

Topics Covered
	y INTRODUCTION TO COMPUTATIONAL THINKING

	y ALGORITHM

	y FLOWCHART

	y SENSORS AND ACTUATORS

	y BREADBOARD AND PCB

http://qr.w69b.com/g/qfEEKPbBm
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COMPUTATIONAL THINKING
TIME: 20 minutes

RESOURCES: For the whole class- different brushes like a paintbrush, toothbrush, makeup brush, 
kid’s toothbrush, soap, two different kinds of toothpaste and tongue cleaner.

ACTIVITY:
1.	 (FOR TRAINERS)

a.	 In your group, assign one teacher as a Robot.

b.	 Write step by step instructions in the space provided below to help the Robot brush its teeth 
in five mins.

c.	 Read the instructions to your Robot and ask the Robot of your group to carry out the instructions 
carefully. 

2.	 (FOR TEACHERS)

a.	 Add the numbers from 1 to 100 in 1 minute.

b.	 Show your work on the activity sheet below.

ACTIVITY QUESTIONS
1.	 Write the instructions that you will read out to a robot to ask it to brush its teeth.  

2.	 Add the numbers from 1 to 100.
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WORKSHEET: COMPUTATIONAL THINKING
THEORY QUESTIONS
1.	 What does computational thinking involve?

	� Thinking like a computer

	� Breaking a complex problem down into simple steps

	� Learning how to program

	� None of the above

2.	 Do you think computational thinking is used only for robots and computers? Where else can we 
use computational thinking?

THINGS YOU CAN DO:
	y Find out where all Computational Thinking is applied in day-to-day life.

	y Try Computational Thinking to solve the below puzzle. 

 
Scribble Space

Use this space to jot down your thoughts
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ALGORITHM
TIME: 20 minutes

RESOURCES: None

ACTIVITY QUESTIONS
Activity-1 Algorithm for preparation of tea. Activity-2 Algorithm for the greatest of two 

numbers
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WORKSHEET: ALGORITHM
THEORY QUESTIONS
1.	 In how many steps did you write the algorithm for preparation of tea?

2.	 An algorithm is --------------------.

	� Pictorial representation

	� Step by step instructions

	� Thinking

	� None of the above 

THINGS YOU CAN DO:
	y Write an algorithm for the activities you did in your previous summer vacation.

	y Write an algorithm on the working of traffic signals. 

 
Scribble Space

Use this space to jot down your thoughts
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FLOWCHART
TIME: 20 minutes

ACTIVITY:
Using the Flowchart symbols, complete the activity questions.

ACTIVITY QUESTIONS
Activity-1 Flowchart for prepration of tea. Activity-2 Flowchart for greatest of the two 

numbers
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WORKSHEET: FLOWCHART
THEORY QUESTIONS
1.	 Flowchart is __________________________________

	� Step by step process of solving a problem 

	� Pictorial representation of a given answer 

	� Diagrams to solve only complex issues 

	� The first step towards coding 

2.	 Which symbol represents the input and output in a flowchart?

THINGS YOU CAN DO:
	y Draw a flowchart to represent the routine followed in your school.

	y Draw the flowchart that describes the steps of your favourite game.

 
Scribble Space

Use this space to jot down your thoughts
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SENSORS & ACTUATORS
TIME: 25 minutes

RESOURCES: For each group: A bunch of neem leaves, a chocolate bar and a lemon. 

ACTIVITY:
	y Choose three participants from your group and ask them to close their eyes.

	y Call a volunteer from the group to distribute some neen leaves, a piece of choclate and a lemon 
wedge to each of the three participants. Then instruct the remaining members of the group to 
observe the facial expressions of the participants as they taste these resource one by one.

ACTIVITY QUESTIONS
1.	 In the activity, ----------------- acts as a sensor and ---------------- as an actuator.

2.	 Name the different parts of the human body, which act as sensors and actuators.
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WORKSHEET: SENSORS & ACTUATORS
THEORY QUESTIONS
1.	 State the difference between sensors and actuators.

2.	 Name the sensor and write one application each for the sensors given below.

   
    

       

THINGS YOU CAN DO:
	y Try reading data sheets of pulse rate sensors.

	y Find out what types of sensors are used in a satellite.

 
Scribble Space

Use this space to jot down your thoughts
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BREADBOARD & PCB
TIME: 30 minutes

RESOURCES: Breadboard, 5 LEDs, 9V Battery, Battery clips, 5 Male to male and 5 Male to female 
jumper cables and PCB.

ACTIVITY:

1.	 Make the connections similar to the image shown.

2.	 And put them in different power rail sockets and check if the LED lights up. 

3.	 Try to make the same circuit on the PCBs 

4.	 Note - While the breadboard is used to make a temporary arrangement, a permanent arrangement 
is made using the PCB by soldering.

ACTIVITY QUESTIONS
1.	 On which area did you connect the LEDs and the power supply of 9V battery?

2.	 Draw a sample sketch of your connection that you constructed on the breadboard.
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WORKSHEET: BREADBOARD & PCB
THEORY QUESTIONS
1.	 What is the purpose of using a breadboard?

2.	 Explain the difference between breadboard and PCB?

THINGS YOU CAN DO:
Try out a simple circuit and make connections in a breadboard to check whether the link is correct or 
not.

 
Scribble Space

Use this space to jot down your thoughts
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COMPUTATIONAL 

THINKING



43

UNIT 7
Arduino

Topics Covered
	y HARDWARE AND INSTALLATION

	y ARDUINO INTERFACE (ARDUINO IDE)

	y ARDUINO LED BLINKING

	y CODING & BASICS

	y ARDUINO TROUBLESHOOTING

http://qr.w69b.com/g/ocrcJ9Oik


44

ARDUINO (HARDWARE & INSTALLATION)
TIME: 30 minutes

RESOURCES: For a group- two Arduino Uno, two USB A to B cable and two laptops.

ACTIVITY:
Complete the below puzzle.

ACTIVITY QUESTIONS
Puzzle: Mention the number in the circle with respect to the parts of Arduino.

1.	 Digital Pins

2.	 Analog Pins

3.	 DC Power Connector

4.	 Power Pins 

5.	 ATMega328 microcontroller

6.	 USB Port ‘B’

7.	 Reset Button
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WORKSHEET: ARDUINO (HARDWARE & 
INSTALLATION)

THEORY QUESTIONS
1.	 How many Analog and Digital pins are there on the Arduino Board? 

2.	 What is Arduino? How is it useful?

THINGS YOU CAN DO:
	y Find out three projects that you can do with Arduino.

	y Discover different types of Arduino boards.

 
Scribble Space

Use this space to jot down your thoughts
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ARDUINO INTERFACE
TIME: 45 minutes

RESOURCES: For each group – Two laptops/computers with Arduino software pre-installed, and two 
Arduino UNO with a USB cable.

ACTIVITY:
1.	 Connect one end of the USB cable to Arduino UNO and the other end to the computer/laptop’s 

USB port.

2.	 Double click on Arduino IDE to open the Arduino programming interface.

3.	 Click on File -> Examples ->Basics ->Blink. (To open sample blink programme for Inbuilt LED)

4.	 Click on Tools -> Board. (Select the Arduino UNO board from the list)

5.	 Click on Tools -> Port. (Select the COM port connected to the Computer)

6.	 Click on Tools -> Programmer. (Select Arduino ISP from the list)

7.	 Click on Sketch -> Verify/Compile. (To check whether the programme is free from errors)

8.	 Click on Sketch -> Upload. (To upload the programme in Arduino)

9.	 Repeat the activity by changing the delay(1000); in the code to delay(3000); and repeat step 8.

ACTIVITY QUESTIONS
1.	 Can we skip the port selection process and upload the programme and why?

2.	 What is the blinking rate of the inbuilt LED on Arduino UNO board during delay(1000) vs 
delay(3000)?
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WORKSHEET: ARDUINO INTERFACE 
THEORY RELATED
1.	 What is the purpose of a serial monitor in Arduino IDE? 

2.	 How to add a library to Arduino IDE? 

THINGS YOU CAN DO:
	y Explore the Fade programme in the examples menu available.

	y Try to connect the LED to pin 13. What did you observe ? Why do you think that happened? 

 
Scribble Space

Use this space to jot down your thoughts
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LED BLINKING
TIME: 30 minutes

RESOURCES: Each Group – 2 Arduino Uno, two sets of three different colours of LED, two 220 ohm 
resistors, 2 Breadboard, and six Jumper wires.

ACTIVITY:
Blinking External LED –In continuation of the Arduino Interface lesson, edit the inbuilt-LED blink 
activity and light up the external LED.

a.	 Connect one jumper wire from GND (“ground”) to one of the (-) columns.

b.	 Place one leg of the resistor in the same column as the GND wire. Place the other leg of the 
resistor in a new row.

c.	 Place the short leg of the LED to the same row as the resistor leg. Place the long leg in a new 
row.

d.	 Connect one jumper wire from the previous row to digital pin 12. (note it can be any digital 
pin)

e.	 Check that your setup matches the setup in the diagram above.

ACTIVITY QUESTIONS
1.	 What happens when you remove the delay ()? 

2.	 Write the steps to upload the sketch you have written to the IDE.

3.	 Can we connect LED to the Analog pin?
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WORKSHEET: LED BLINKING
THEORY BASED QUESTIONS
1.	 Can you connect more than one LED and blink simultaneously?

a.	 YES 

b.	 NO

2.	 What happens if the ground pin is not connected?

THINGS YOU CAN DO:
	y Make series and parallel connection with LEDs on a breadboard and connect them with Arduino 

UNO.

	y Make a traffic signal model using LEDs and Arduino.

	y Use LEDs to make something similar to the Diwali lights patterns.

 
Scribble Space

Use this space to jot down your thoughts
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CODING & BASICS
TIME: 20 minutes

RESOURCES: For each group: Laptop installed with Arduino IDE, pushbutton, LED, 10K ohm resistor, 
10 Jumper cable M-M, USB A to B cable, Arduino UNO & Breadboard.

ACTIVITY:
1.	 Turns on and off a light-emitting diode (LED) using pushbutton.

2.	 Connect the component, as shown in the above image.

a.	 LED attached from pin 13 to ground

b.	 pushbutton attached to pin 2 from +5V

c.	 10K ohm resistor attached to pin 2 from ground

3.	 Now open Arduino IDE & write a program as shown.

4.	 Connect the Arduino UNO with the computer using USB A to B cable.

5.	 Now upload the program to Arduino, please remember to select board & port before uploading.
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WORKSHEET: CODING & BASICS
THEORY QUESTIONS
1.	 Why we use void before loop & setup function? 

2.	 What is difference between == & = ?

3.	 Which Statements are true or false?

a.	 We can also write int loop() instead of void loop(). 			   (True/False)

b.	 Instead of pinMode() we can write readPIN().				    (True/False)

c.	 Arduino IDE programming is case sensitive language. 			   (True/False)

d.	 A void loop will run once, whereas setup will run multiple times.	 (True/False)

4.	 In which other scenarios can we use “if & else”?  

THINGS YOU CAN DO:
	y Write a program to control a LED & Buzzer with two different Pushbuttons.

	y Control 8 different LEDs to make them glow in a different pattern using two pushbuttons.

 
Scribble Space

Use this space to jot down your thoughts
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ARDUINO TROUBLESHOOTING
TIME: 30 minutes

RESOURCES: Laptop with Arduino software pre-installed, Arduino UNO with a USB cable, Servo 
motor and Male to male Jumper Cables.

ACTIVITY:
1.	 Connect the Arduino UNO board with laptop via USB cable and check if the inbuilt LEDs are 

working on the board.

2.	 Connect the Arduino and write the mentioned code on IDE.

Yellow wire------Signal pin

Red wire---------+5V

Black Wire------GND(Ground)

Note: The signal pin in a servo motor connection should always be assigned to PWM (Pulse Width 
Modulation) Pins .

PWM pin numbers: 3, 5, 6, 9, 10 ,11

3.	 Troubleshoot the errors in the programme.

4.	 Observe the behaviour of the servo motor.
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ACTIVITY QUESTIONS
1.	 List out the errors you got while verifying the programme in Arduino IDE?

2.	 Can we add signal pin of Servo motor to any digital pin on Arduino UNO?

	� Yes

	� No

 
Scribble Space

Use this space to jot down your thoughts
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WORKSHEET: ARDUINO TROUBLESHOOTING
THEORY QUESTIONS
1.	 What are the applications of servo motor in real life?

2.	 If you receive a board error in the IDE what would be the steps to solve?

THINGS YOU CAN DO:
	y Take some sample programmes from the Arduino IDE and introduce a few errors in them and ask 

other participants to troubleshoot.

 
Scribble Space

Use this space to jot down your thoughts
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SENSOR BASED ACTIVITY
TIME: 20 minutes

RESOURCES: Sensor-based Activity Sheets ( 2 for each group).

Common Resource Two sensors for each group

Arduino UNO MQ -2/ MQ-135/MQ-7

USB A to B Ultrasonic Sensor

Jumper cable (M-M)/(F-F)/M-F) 10 each DHT – 11

Breadboard LDR Module

LEDs PIR Module

Laptop Sound Sensor

Buzzers Soil Moisture Sensor

Push Buttons Rain Drop Sensor

Pulse Rate sensor

ACTIVITY:
Select any two sensors and take the respective activity sheet from the Annexure 2 (Page 118 - 143). 
Do as mention on the activity sheets. 

ACTIVITY QUESTIONS
1.	 Which sensor did you use? What is the working principle of your sensor?

2.	 Can we operate a sensor without a micro-controller?

	� Yes

	� No

3.	 List out the sensors that other teams are using

THINGS YOU CAN DO:
	y Try working on the different sensors available in your ATL Lab. 

	y Try using switches, LCD in place of LEDs and Buzzers.



56

EXPLORING
ARDUINO
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UNIT 8
3D Printing

Topics Covered
	y INTRODUCTION TO 3D PRINTING

	y 3D MODELLING

	y TROUBLESHOOTING

http://qr.w69b.com/g/sJdtAvMwo
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INTRODUCTION TO 3D PRINTING
TIME: 30 minutes

RESOURCES: For a group of 3 participants: Thermocol sheet, Cutter, Glue, & Sketch Pens.

ACTIVITY:
1.	 Take the thermocol sheet.

2.	 Cut out three sets of 2 different shapes from it. (Circle & Rectangle).

3.	 Paste the cut outs of the same shape one over the other. 

4.	 Colour the objects (Optional).

ACTIVITY QUESTIONS
1.	 Which shape did you get when you placed :

a.	 Circles on circle 

b.	 Rectangles on Rectangle
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WORKSHEET: INTRODUCTION TO 3D 
PRINTING

THEORY QUESTIONS
1.	 What is additive manufacturing?

2.	 Which 3D printer do we use in our lab?

a.	 Power Bed Binder 

b.	 Fused Deposition Modelling 

c.	 Stereolithography

d.	 Selective Laser Sintering 

THINGS YOU CAN DO:
	y Find out the different areas in which 3D printing is used.

	y Which shape do you think you will get if you convert triangle into 3D using layer by layer process? 

 
Scribble Space

Use this space to jot down your thoughts
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3D MODELLING
TIME: 40 minutes

RESOURCES: Play Dough & blank paper (A4).

ACTIVITY:
1.	 Using playdough & build a keychain. 

2.	 Notice all the steps you had to do to build the Keychain. 

THINGS YOU CAN DO:
	y You can design your own model using clay.

	y Try your hands on 3D builder & Autodesk 123D 

 
Scribble Space

Use this space to jot down your thoughts
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TROUBLESHOOTING
TIME: 20 minutes

RESOURCES: Blank Paper (A4 sheet).

ACTIVITY:
1.	 Try to level the gap between the nozzle & bed. 

2.	 Look at automatic levelling and how to change levelling on one side. 

ACTIVITY QUESTIONS
1.	 What should be the minimum distance between the bed and the nozzle? 

2.	 What are the steps invoved in automatic levelling? 
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WORKSHEET: TROUBLESHOOTING
THEORY QUESTIONS 
1.	 What are the causes of the print not sticking to the bed? 

2.	 What would you do if the extruder is clogged?  

THINGS YOU CAN DO:
	y Check the quality of filament.

	y Try to make a model with two colours in a single nozzle printer.

 
Scribble Space

Use this space to jot down your thoughts
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CREATING
3D
MODELS
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UNIT 9
Observing Safety & Security 

Topic Covered
	y SAFETY & SECURITY

http://qr.w69b.com/g/lZbRkR2QE
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SAFETY & SECURITY
TIME: 20 minutes

RESOURCES: For every group: dismantled pens of different colours in a pouch, a Timer and a checklist 
sheet.

ACTIVITY:
Part A: Go around the lab and “tick or cross” in the sheet with the list of safety regulations. 
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Part B: Select two participants from your group and ask them to come forward to perform the 
activity. Name the participants as A and B.  

a.	 Give the resources to participants.

b.	 Set the timer and ask person A to assemble the pen.

c.	 Once he/she finishes the task, stop the timer. 

d.	 Next, ask person B to arrange the dismantled parts of the pen in the way they want, before 
starting the timer.

e.	 Ask person B to start assembling the pen and note down the time taken and also note the 
difference in the time taken to complete the task by each participant.

ACTIVITY QUESTIONS
1.	 Why is it important to label all the materials in the lab? 

2.	 Who assembled the pens in the less time in part B of the activity and why?
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WORKSHEET: SAFETY & SECURITY
THEORY QUESTIONS 
1.	 Which “S” is essential and why? 

2.	  What are the steps one must take to observe safety and security in your ATL Lab?  

THINGS YOU CAN DO:
	y Check whether the primary safety measures are followed in your ATL lab.

	y Make a follow-up sheet of 5 S and keep updating regulary by observing the ATL lab.

 
Scribble Space

Use this space to jot down your thoughts
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LEARNING
STEPS
FOR
SAFTEY
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UNIT 10
Mechanical Tools 

Topics Covered
	y MECHANICAL TOOLS

	y POWER TOOLS

	y MEASUREMENT TOOLS

http://qr.w69b.com/g/rEgbb54s0
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MECHANICAL TOOLS
TIME: 20 minutes

RESOURCES: All the 18 Mechanical tools and labels of all the 18 tools in a bowl.

ACTIVITY:
1.	 Divide the whole class into two groups keep half the mechanical tool on the table at the centre. 

2.	 Select two volunteers from each group and ask them to come forward to perform the activity. 
Other team members have to guide the volunteers to perform the activity.

3.	 Ask each group’s volunteer to pick up nine chits from the bowl. 

4.	 Ask them to place the chits next to the tools and arrange the tools on the table based on their 
purpose. 

ACTIVITY QUESTIONS
1.	 Write the names of the new tools you learnt today in activity?  
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WORKSHEET: MECHANICAL TOOLS
THEORY QUESTIONS 
1.	 What is the difference between adjustable wrench and spanner? 

2.	 What is the difference between adjustable wrench and spanners?

THINGS YOU CAN DO:
	y Write down the safety measures to be taken while using the mechanical tools.

	y Display the instructions to follow while using the mechanical tools near the mechanical tools 
station. 

 
Scribble Space

Use this space to jot down your thoughts
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POWER TOOLS
TIME: 30 minutes

RESOURCES:  (Power Drill, Cardboard), (Glue Gun and two pieces of Sunboards), (Hot Air Gun and 
two boards attached with a Glue Gun), and (Safety Goggles, Hand Gloves and Face Mask).

ACTIVITY:
1.	 Each group to choose one station either Power Tools/Glue Gun/Hot Air Gun.   

	� Power Drill Activity – Create holes on the Cardboard to make the letter ”L”.

	� Hot Air Gun Activity-  Use the Hot Air Gun to remove the adhesive from the two boards.

	� Hot Glue Gun Activity - Apply Glue Gun and try to attach the two Sunboard 

2.	 Groups can shuffle their stations as soon as they have completed. 

ACTIVITY QUESTIONS
1.	 What is the perfect angle to use the Power Drill?  

2.	 Can we screw or unscrew things using a Power Drill?  
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WORKSHEET: POWER TOOLS
THEORY QUESTIONS 
1.	 What material is used to make glue sticks that is used in a hot glue gun? 

2.	 What are the advantages of using a hot air gun?

THINGS YOU CAN DO:
	y Observe the things present in your home like a switchboard, tables, hangers etc. and try to find 

out the device used to make or attach the daily use items in your household.   

 
Scribble Space

Use this space to jot down your thoughts
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MEASUREMENT TOOLS
(VERNIER CALIPER, MULTIMETER, DIGITAL OSCILLOSCOPE, SPIRIT LEVEL, & 

MEASUREMENT TAPE)

TIME: 30 minutes

RESOURCES:  For a group of participants (Vernier Caliper, Multimeter, Digital Oscilloscope, Spirit 
Level & Measurement Tape). 

ACTIVITY:
1.	 Vernier Caliper:  Take a bottle cap, measure its inner as well as outer diameter & try to design it in 

3D CAD software.

2.	 Multimeter: Take a battery & five different resistors. Try to check the Voltage & Ampere of the 
battery & the resistance of resistor.

3.	 Digital Oscilloscope: Try to check the wavelength of the Hand/body Current.

4.	 Spirit Level: Check the level of the table to ensure whether the table is tilted or not.

5.	 Measurement tape: Try to measure the dimensions of the table & record it in your notebook.
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WORKSHEET: MEASUREMENT TOOLS
ACTIVITY QUESTIONS 
1.	 Measure your bottle using a vernier caliper and write the measurement below.

2.	 Write the value of the component using Multimeter.

3.	 What wave did you see?

	� Analog

	� Digital

4.	 Is your table tilted or slanted.

5.	 Write the measurement of the table.

	� Height

	� Width

	� Length 

 
Scribble Space

Use this space to jot down your thoughts
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WITH 
TOOLS
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UNIT 11
Soldering

Topic Covered
	y SOLDERING

http://qr.w69b.com/g/qSQp3RxW8
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SOLDERING
TIME: 45 minutes

RESOURCES:  Soldering iron, soldering station (subject to availability), solder, DE soldering wick, 
Solder paste, General Purpose PCB Board, Safety gloves, Face Mask and Safety Goggles, 9v Battery 
with Battery clip, 5 LEDs, few strands of wires. 

ACTIVITY:
1.	 Use the general-purpose PCB to make a circuit using the LEDs and use the battery to provide 

power to the circuit.

ACTIVITY QUESTIONS
1.	 Which side of the PCB is used in soldering? 

2.	 How will you DE-solder the components from the board? 
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WORKSHEET: SOLDERING
THEORY QUESTIONS 
1.	 What is the material used in solder? 

2.	 What is the heating temperature of the metal tip in a soldering iron?

THINGS YOU CAN DO:
	y Dismantle the electronic components which are not in use to visualize the PCB present inside.

 
Scribble Space

Use this space to jot down your thoughts
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SOLDERING
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UNIT 12
Raspberry PI

Topics Covered
	y INTRODUCTION

	y A TOUR OF PI

http://qr.w69b.com/g/sCchTKk7u
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INTRODUCTION TO R-PI
TIME: 45 minutes

RESOURCES:  For a group of 3 Participants - Raspberry Pi 

Hardware- A Raspberry Pi with a 32GB SD card, a monitor with a cable (and, if needed, an HDMI 
adaptor), a USB Keyboar, a mouse & a power supply

Software- Raspbian, installed via NOOBS

ACTIVITY-1:
1.	 Observe the Raspberry Pi & its components embedded on Green PCB and answer the questions 

below.

ACTIVITY QUESTIONS
1.	 Label the above diagram. 

 
1.	 HDMI Port

2.	 Micro SD card Slot

3.	 General Purpose Input/Output 
Pins (GPIO)

4.	 Ethernet Port

5.	 USB Port

6.	 Audio Jack  

7.	 Micro USB Power
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WORKSHEET: INTRODUCTION TO R-PI
THEORY QUESTIONS 
1.	 How many USB can be connected to R-PI 3? 

2.	 What is Raspberry Pi? What is the difference between Raspberry Pi and Arduino? 

3.	 What should be the memory capacity of the SD card used for the installation process? 

 THINGS YOU CAN DO:
	y Try using a Pen drive of 32 GB in place of a memory card for installing Raspberry Pi 

	y Explore the programming languages which can be used in Raspberry Pi. 

 
Scribble Space

Use this space to jot down your thoughts
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A TOUR OF PI
TIME: 20 minutes

RESOURCES:  A Raspberry Pi connected to screen connected with a mouse and keyboard.

WORKSHEET:
1.	 How many GPIO Pins are there in Raspberry Pi 3? 

2.	 What does GND stand for? 

3.	 Connect 10 LEDs to Raspberry Pi & make them blink them at random. 

 THINGS YOU CAN DO:
	y Make the LED antenna stay on for longer.

	y Make the LED flash more than once.

	y Record your own sound to be used by the Robot — get creative!

 
Scribble Space

Use this space to jot down your thoughts
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RASPBERRY
PI
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UNIT 13
Business Pitch

Topic Covered
	y BUSINESS PITCH

http://qr.w69b.com/g/mlAglsYO4
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BUSINESS PITCH 
TIME: 30 minutes

RESOURCES:  None.

ACTIVITY:
1.	 Draw a unique coffee mug in the space provided below  

2.	 Select a any group member to come forward and present his/her mug to the audience as if they 
were presenting before the buyers in one minute.

3.	 Set the timer to 1 minute  before you start presenting.

ACTIVITY QUESTIONS
1.	 What are some other ideas you could have presented in your business pitch? 



88

 
Scribble Space

Use this space to jot down your thoughts
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PRESENTING

INNOVATIONS
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UNIT 14
ATL Best Practices

Topics Covered
	y ESTABLISH

	y ENABLE

	y CELEBRATE

http://qr.w69b.com/g/qwvFU2hry


91

Objective
The ATL program has demonstrated positive early results, with several learnings and insights, that are 
being incorporated into the program design in real time. No two schools are same due to diversity 
in region, students, ethnicity, culture, affiliation, management and faculties. Geographical variations 
have revealed different types of best practices, that may be adopted regionally or nationally. There 
are a growing number of schools which have found simple and effective ways to overcome their local 
hurdles.

This ATL Best Practices Guide attempts to document some of the most innovative practices which 
schools have successfully implemented in their ATLs. These best practices will enable and empower 
more schools to successfully manage their ATLs.

The ATL Best Practices Guide contains fourteen simple solutions from different regions of India and are 
categorized according to the ATL framework of Selection, Establishment, Enablement and Celebration. 
The solutions scribed in this guide keeps the ATL in-charge and school management in mind. The 
practices provided are simple and easy to implement for any school, regardless of its circumstances.

Best Practices

The best practices are organized as per the framework, “Establish, Enable, and Celebrate.”

Establish Enable Celebrate

	y Setting up of key  processes.

	y E.g. Conducting daily 
classes, organizing key ATL 
events, and designing the 
curriculum..

	y Building human resource 
strength, skills, knowledge, 
and equipment in 
innovative ways.

	y E.g. Engaging the 
community, parents, 
mentors, and school 
management.

	y Appreciating key 
stakeholders for their 
engagement with the ATL. 

	y E.g. celebrating innovative 
projects by students.

Best Practices framework
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Every bucket has been further divided into sub-categories:

Establish Enable Celebrate

Daily Classes

1.	 Peer to Peer Learning and 
Mentoring.

2.	 Mixed Age Classroom 
Learning

Engaging School Teachers & 
Administration

1.	 Surprise ATL Visits by the Principal.

2.	 Distributing ATL In-Charge Duties 
Among Teachers

Events to Celebrate.

1.	 Conducting Intra 
School Competitions.

Knowldege & Capacity 
Building

1.	 Developing an ATL 
Curriculum.

2.	 Designing an ATL Textbook

Engaging Students & Parents

1.	 Engaging students from Non-
Science Streams

2.	 Introducing Parents to the ATL.

3.	 Understanding Community Issues 
through Parents Engagement.

Projects

1.	 Showing Students 
Projects.

Engaging the Community.

1.	 Engaging with Community 
Mentors.

2.	 Conducting Regular ATL 
Community Classes.

3.	 Field Trips to understand 
Community Challenges.

Best Practices Framework: Sub-Categories
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ESTABLISH
PEER TO PEER LEARNING AND MENTORING

WHAT IS THE BEST PRACTICE?

Identify ATL students to volunteer as ‘student mentors’ to take ATL sessions for school children and 
teachers.

HOW IS IT DONE?

1.	 Select a few committed students and designate them as ATL student mentors.

2.	 Involve ATL student mentors while planning ATL sessions and curriculum.

3.	 Allow ATL students mentors to take sessions for all students and interested teachers.

4.	 The ATL in-charge should be present to supervise and answer students’ doubts.

WHY IS IT IMPORTANT?

Peer to peer learning enables the ATL in-charge to save time and focus on additional ATL work.

Advantages

ATL In-Charge

Time Management

ATL Student Mentor

Leadership Experience

Other Students

Faster Learning Curve

Advantages of Peer to Peer Learning and Mentoring
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MIXED AGE CLASSROOM LEARNING

WHAT IS THE BEST PRACTICE?

Conduct ATL classes during a common period so that students of different classes and age groups 
can work together in teams.

HOW IS IT DONE?

1.	 Schedule ATL sessions during a common period such as the prayer hour.

2.	 Divide students into mixed-age sub-groups while working on projects. E.g., students from class 6, 
7, and 8 can work together in groups.

3.	 Encourage students across ages to be amicable and supportive of each other.

WHY IS IT IMPORTANT?

With mixed age classrooms, students learn teamwork, which is one of the most important 21st century 
skills. They improve their leadership and communication skills and learn to support one another.

Both

Teamwork, 
Communication
, Enhanced 
Learning

Older students 
Gain

Leadership, 
Sensitivity

Younger 
Students Gain

Mentorship, 
Independence

Advantages of Mixed Age Classroom Learning
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DEVELOPING AN ATL CURRICULUM

WHAT IS THE BEST PRACTICE?

Design a curriculum as per the school’s students’ capabilities and available equipment. This provides 
structure to ATL classes and ensures their sustainability.

HOW IS IT DONE?

1.	 Define month-wise and session-wise topics to be covered in classes.

2.	 Include practical and theoretical sessions.

3.	 Introduce concepts a year in advance so that students are familiar with it later. E.g. In class 8, 
demonstrate soldering to students. In class 9, they can try soldering themselves.

4.	 In case of transfer or job change, handover the document to the next in-charge.

WHY IS IT IMPORTANT?

A well-defined curriculum structures ATL classes and ensures their sustainability.

ATL Session Gains

Customization

Step by Step Learning

Structure

Tailored to each ATL

Sustainability

Consistency over Time

Advantages of Developing an ATL Curriculum
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DESIGNING AN ATL TEXTBOOK

WHAT IS THE BEST PRACTICE?

Write a textbook that covers all the important technological concepts tailored to the ATL needs, 
equipment, and student’s level of understanding.

HOW IS IT DONE?

1.	 Combine relevant information from the websites of open source software’s, AIM website, and ATL 
teacher training material.

2.	 Focus on explaining key concepts. E.g. how various electronic components work.

3.	 Supplement the textbook with other sources. E.g. educational videos online.

WHY IS IT IMPORTANT?

An ATL textbook consolidates the students’ knowledge, provides structure to classes, and ensures 
sustainability and replicability of ATL classes.

Defines ATL Class 
Structure

Consolidates 
Student Learning

Ensures 
Sustainability of 

ATL Classes

Advantages of Designing an ATL Textbook
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ENABLE
SURPRISE ATL VISITS BY THE PRINCIPAL

WHAT IS THE BEST PRACTICE?

The Principal or Vice-Principal can demonstrate an active interest in the ATL by attending an ATL 
session once a month and taking updates from the ATL in-charge.

HOW IS IT DONE?

1.	 Co-ordinate monthly ATL sessions which the Principal can attend with students.

2.	 During sessions, the Principal can work with students, share scientific discoveries, etc.

3.	 The Principal can also schedule regular check-ins with the ATL in-charge to receive updates on the 
sessions.

WHY IS IT IMPORTANT?

If the Principal demonstrates interest in the ATL’s activities, then the students feel motivated and

the in-charge is kept accountable.

Both

Motivation

ATL In-Charge

Accountability

Students 

Encouragement

Advantages of surprise ATL visits by the Principal
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ENGAGING STUDENTS FROM NON-SCIENCE STREAMS

WHAT IS THE BEST PRACTICE?

Organize regular ATL activities for across streams — Commerce, Humanities, Science, and Vocational 
— to inculcate a problem-solving mindset in all students.

HOW IS IT DONE?

1.	 Organise hands-on monthly workshops on technology and innovation. E.g. the launching of 
satellites.

2.	 Workshops may be conducted by local experts, for example, professors from neighbouring 
engineering colleges.

WHY IS IT IMPORTANT?

A diverse group of students across streams feel motivated to engage with the ATL. This encourages 
innovative problem solving from multiple perspectives as students from different disciplines may 
tackle problems in unique ways.

Both

Inter-
Disciplinary 

Problem 
Solving

Non-Science 
Stream Students

Expanded 
Perspectives

Students 

Enriched 
Learning 

Experience

Advantages of engaging students from non-science streams 
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INTRODUCING PARENTS TO THE ATL

WHAT IS THE BEST PRACTICE?

Introduce parents to the ATL through exhibitions and live demonstrations during the school’s cultural 
events.

HOW IS IT DONE?

1.	 Organise ATL exhibitions during cultural celebrations. E.g. Republic Day or Sarasvati Pooja.

2.	 Students can give live demonstrations of their projects to the visiting parents. They can also explain 
how their project addresses community challenges.

WHY IS IT IMPORTANT?

By experiencing ATL projects first-hand, parents are more inclined towards their child’s participation 
in the ATL. When parents share their experience with family and friends, the community also learns 
about the students’ achievements.

Parent 
Engagement

Community 
Outreach

Student 
Motivation

Advantages of introducing parents to the ATL
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UNDERSTANDING COMMUNITY ISSUES THROUGH PARENT ENGAGEMENT

WHAT IS THE BEST PRACTICE?

Engage with parents to gain insights into the common challenges of their community. E.g. in an 
agrarian region, students can visit parents who are farmers to learn about issues in food storage, 
transportation etc.

HOW IS IT DONE?

1.	 Focus on tackling a challenge that’s important to your community. E.g. Food storage in an agrarian 
region.

2.	 Connect with parent experts. E.g. A farmer

3.	 Organise a field trip to visit the parent at the relevant site. E.g. The parent’s farm.

4.	 Later, ask the students about what they observed. Help to brainstorm solutions.

WHY IS IT IMPORTANT?

Engaging with the parents help students gain deep insights into community challenges and design 
sustainable solutions. The in-charge can engage with the community through organic networks. The 
parents feel engaged with the ATL.

Advantages

Students

Bridging of ATL and Community

Parents

Engagement with ATL

ATL In-Charge

Organic Community Outreach

Advantages of understanding community issues through parent engagement
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ENGAGING WITH COMMUNITY MENTORS

WHAT IS THE BEST PRACTICE?

Connect with innovators in the community who are knowledgeable in technology as ‘community 
mentors.’

HOW IS IT DONE?

1.	 Reach out to community members who are technology experts. E.g. nearby engineering college 
or IT company.

2.	 Invite them to visit the Tinkering Lab.

3.	 Discuss the possibility of a structured and sustained engagement. E.g. Monthly workshops or 
trouble-shooting sessions.

4.	 Ensure sustainability through regular communication and follow-ups. E.g. JR Dani school has tied 
up with NIT Raipur’s computer science department. College students

5.	 Pay monthly visits to help students fix problems in their projects.

WHY IS IT IMPORTANT?

With community mentors, ATLs receive guidance and support from their community.

Students
Enhanced 
Learning

In-Charge
Sustained 

Community 
Outreach

Mentors
Opportunity 

for Community 
Service

Advantages of engaging with community mentors



102

ENGAGING WITH COMMUNITY MENTORS

WHAT IS THE BEST PRACTICE?

Conduct weekly ATL classes for disadvantaged students from the community.

HOW IS IT DONE?

1.	 Invite neighbouring schools to send their students for ATL classes. E.g. state/ central government 
schools can focus on inviting their district’s Nagar Nigam schools.

2.	 Conduct weekly classes for a select group of interested community students.

3.	 Invite regular ATL students to attend sessions and partner with community students on projects.

4.	 Encourage the community students to visit the ATL during afterschool hours to work on projects.

WHY IS IT IMPORTANT?

By attending regular ATL classes over a long period, community students can access new opportunities 
and expand their skillset. Regular ATL students can work with new students who bring in a fresh 
perspective. This results in a far-reaching and impactful community engagement.

Community Students
Expand their 

Knowledge and Skills

Regular ATL Students
Learn teamwork and 

Communication

The Community
Builds an Ecosystem  

of Innovation

Advantages of conducting regular ATL community classes
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FIELD TRIPS TO UNDERSTAND COMMUNITY CHALLENGES

WHAT IS THE BEST PRACTICE?

Take the ATL class on a field trip to local spaces where they can observe common challenges and 
brainstorm solutions relevant to their community. This does not necessarily have to be a museum or 
research institute. Instead, it can be nearby farms, busy roads, railways, polluted water bodies etc.

HOW IS IT DONE?

1.	 Schedule a field trip where students can observe community challenges in real time. E.g. highway 
where accidents are common.

2.	 Have students speak with experts. E.g. Police officers in a nearby traffic control room.

3.	 After the visit, ask students about the challenges they observed and help them brainstorm solutions. 
E.g. A traffic signalling system to prevent accidents.

WHY IS IT IMPORTANT?

Through community-based field trips, students learn to connect innovation with real-world problems. 
This helps the school to build an ecosystem of innovation which is rooted in relevant community 
challenges.

Focus on locally 
relevant solutions

Ecosystem of 
innovation in school 

and community

Analytical 
understanding of 

community challenges

Advantages of field trips to understand community challenges
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FIELD TRIPS TO UNDERSTAND COMMUNITY CHALLENGES

WHAT IS THE BEST PRACTICE?

Distribute ATL in-charge duties among interested teachers to ensure daily support and long-term 
sustainability for the lab.

HOW IS IT DONE?

1.	 Constitute an ATL committee from among the interested teachers.

2.	 Distribute responsibilities between the in-charges based on their capabilities.

3.	 During ATL sessions, more than one in-charge should be present to provide hands-on support.

4.	 Send more than one in-charge for the teacher training session when it is conducted.

WHY IS IT IMPORTANT?

Appointing a deputy in-charge provides much needed support to the ATL in-charge and also creates 
a more sustainable Tinkering Lab.

ATL Gains

ATL In-Charge

Receives ATL –related support

Students

Hands-on guidance

ATL Committee

Motivation with Additional 
role

Sustainability

Advantages of distributing ATL in-charge duties among teachers
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CELEBRATE
CONDUCTING INTRA-SCHOOL COMPETITIONS

WHAT IS THE BEST PRACTICE?

Organize intra-school competitions to motivate students with a budding interest in innovation who 
have not yet represented the school in external competitions.

HOW IS IT DONE?

1.	 Organise friendly competitions in the school. E.g. Inter-house, among classes or sections.

2.	 After the event, appreciate the winners. E.g. give school-issued certificates or congratulate them 
in the school assembly.

3.	 Conduct such events regularly so that students keep building confidence.

WHY IS IT IMPORTANT?

Intra-school competitions encourage more students to build their confidence in the ATL. Friendly 
tournaments are a stepping stone to inter-school competitions.

Intra-School Competitions

Students
• Confidence
• Teamwork
• Higher standards of achievement

School
• Intra-school events are a training ground for 

state and national competitions

Advantages of conducting intra-school competitions
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SHOWCASING STUDENT PROJECTS

WHAT IS THE BEST PRACTICE?

Have regular themes on which students can create project every month. Appreciate the best projects 
by showcasing them outside the ATL.

HOW IS IT DONE?

1.	 Give students new project themes each month. E.g. “Wealth from Waste”.

2.	 At the end of the month, showcase the best three projects in the school.

3.	 Maintain a mode of communication such as a social media group with parents and students to 
share achievements.

WHY IS IT IMPORTANT?

Intra-school competitions encourage more students to build their confidence in the ATL.  Friendly 
tournaments are a stepping stone to inter-school competitions. Regular communication with parents 
about students’ achievements motivates both students and parents. Together, these practices create 
an ecosystem of innovation.

Monthly Themes
Push Students to 
engage with new 

challenges. 

Appreciation
Builds student’s 

confidence

Parent-Teacher 
Communication

Increases parental 
support for the ATL 

Together, this 
builds an 

ecosystem of 
innovation.

Advantages of showcasing student project



GLIMPSES



Annexure 1

Topics Covered
	y GRANT IN AID FUND UTILIZATION FOR ATL SCHOOLS
	y ATL ADVISORY COMMITTEE
	y INTEGRATE ATL IN SCHOOL CURRICULUM
	y ATL EVENTS AND CALENDARS
	y ATL DASHBOARD
	y ATL QUERY RESOLUTION
	y MENTOR INDIA PROGRAM
	y ATAL INCUBATION CENTRE

http://qr.w69b.com/g/m7Sbro2qs
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GRANT IN AID FUND UTILIZATION FOR ATL 
SCHOOLS 

1.	 Go to www.aim.gov.in

2.	 Click on the Atal tinkering Labs Tab.

3.	 Under that category place the cursor on ATL Establishment.

4.	 Under that category click on Guidelines for ATL Establishment.

5.	 Under that category click on Guidelines.

6.	 Click on Grant in aid fund utilization for ATL schools.

QUESTIONS
1.	 How much money is allocated for one-time establishment cost?

2.	 How much money is allocated per year towards operation and maintenance?

3.	 Can you buy printer, speakers or CCTV from the grant in fund aid?

4.	 Where will you remit the interest accumulated on bank deposit of the grant?
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ATL ADVISORY COMMITTEE
THEORY QUESTIONS
1.	 Go to www.aim.gov.in

2.	 Click on the Atal Tinkering Labs Tab.

3.	 Under that category click on ATL Establishment.

4.	 Under that category click on Guidelines for ATL Establishment.

5.	 Under that category click on the ATL OPERATIONAL MANUAL tab.

6.	 Go to page no. 18 in the pdf file and start reading from there.

QUESTIONS
1.	 What is the purpose of creating an advisory committee?

2.	 Who are the members of the ATL Advisory Committee? 

3.	 What are the roles and responsibility for the ATL in-charge in the lab?

4.	 Who is in charge of monitoring and evaluating the ATL in charge on a regular basis?
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INTEGRATE ATL IN SCHOOL CURRICULUM 
THEORY QUESTIONS
1.	 Go to www.aim.gov.in

2.	 Click on Atal Tinkering Labs tab.

3.	 Under that tab place your cursor in ATL Establishment.

4.	 Then click on Guidelines for ATL Establishment. 

5.	 Click on the video on how to integrate ATL in School Curriculum.

QUESTIONS
1.	 How you will manage time for conducting classes for the students?

2.	 How will you create Tinker club?

3.	 Who can nominate the students for tinker lab?

4.	 Who can encourage the students to solve real life problems?
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ATL DASHBOARD
THEORY QUESTIONS
1.	 Go to www.aim.gov.in

2.	 Click on Atal Tinkering Labs tab.

3.	 Under that category, move to My ATL.

4.	 Click on Dashboard to open your dashboard.

5.	 Click on MY ATL USER MANUAL to know the instructions for filling up the ATL Dashboard.

QUESTIONS
1.	 Which step you should fill after filling the school general information?

2.	 Upto how many mentors you have to fill in the ATL Mentor Registration Form?

3.	 If a school wishes to change the already submitted/registered ATL contact information, then which 
option has to be used in order to change?

4.	 How many sections is the ATL Monthly Report section divided into? Name them.
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ATL QUERY RESOLUTION
1.	 Go to www.aim.gov.in

2.	 Click on Atal Tinkering Labs tab.

3.	 Under that tab click on ATL Helpline-Query Resolution

QUESTIONS
1.	 Under which category can you register a query related to ATL Tinkering marathon?

2.	 Whose email id will you enter in the “email of complaint” box? 

3.	 What would you need to track your queries?

4.	 Which sub category will you use to raise a query when you are unable to save the data?
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MENTOR INDIA PROGRAM 
THEORY QUESTIONS
1.	 Go to www.aim.gov.in

2.	  Click on the Mentor of Change Tab.

3.	 To get information about how to become a mentor place the cursor on “Be a Mentor tab”.

4.	 Click on Mentor Training tutorial if you want to get information regarding training modules.

QUESTIONS
1.	 What is the ongoing commitment a mentor has to make with the school?

2.	 Who can apply for a mentor?

3.	 What is the first step a mentor has to follow before mentoring any school?

4.	 What is the first step a mentor has to follow before mentoring any school?
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ATAL INCUBATION CENTRE 
1.	 Go to www.aim.gov.in

2.	 Click on Atal Incubation Center tab.

3.	 Click on What is an incubator tab to know about an incubator.

4.	 Click on Atal Incubation Centers to get more details regarding Atal Incubation Centers.

5.	 Click on “revised guidelines for setting up of AIC” tab Atal Incubation Centers tab.

QUESTIONS
1.	 What is the purpose of setting up Atal incubation Centers?

2.	 How much grant in aid is provided to the successful applicants?

3.	 What is SPV and how it can be used for Atal incubation Centers?

4.	 What is minimum requirement of space for setting up an Atal Incubation Centers? 
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Annexure 2

Topics Covered
	y MQ GAS SENSOR
	y ULTRASONIC SENSOR
	y DHT 11 – TEMPERATURE AND HUMIDITY SENSOR
	y LDR MODULE
	y PIR SENSOR
	y SOUND SENSOR
	y SOIL MOISTURE SENSOR
	y WATER LEVEL SENSOR
	y RAINDROP SENSOR

http://qr.w69b.com/g/nKHvUx3HO


118

MQ GAS SENSOR
INTRODUCTION
MQ gas sensors are a family of sensors which are used to detect a wide variety of gases like alcohol, 
smoke, methane, LPG, hydrogen, NH3, Benzene, Propane etc. These sensors are made up of electrode 
which is coated with a sensing material, and it is heated to make it more reactive and sensitive. When 
the gas reacts with these electrodes, its resistance changes, more the gas, less is the resistance and 
vice-versa.

Here is a list of different sensors with their respective gas detection

Sensor Gas Detected

MQ 2 General combustible gas

MQ 3 Alcohol

MQ 4 Methane, Natural gas

MQ 5 LPG, natural gas, coal gas

MQ 6 LPG, Propane

MQ 7 Carbon Monoxide

MQ 135 Air quality control

OBJECTIVE
During this activity, you will help students to achieve following objectives:

	y Understanding principle and operations of MQ Gas sensor.

	y Design algorithm and flowchart to sense moisture of soil using MQ Gas sensor.

	y Programming MQ Gas sensor using Arduino API for Arduino Genuino UNO. 

	y Interfacing MQ Gas sensor with Arduino Genuino UNO using analog pin A0.

APPLICATION
All the MQ series gas sensors can be used according to their ability to detect the different gases.

Some examples are indoor air quality, pollution detection system, hazardous gas detector, LPG leakage 
detector and alarm, etc.
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ALGORITHM: FLOWCHART:

Step 1	Assign analog pin A0 to MQ GAS Sensor

Step 2	Define and initialize Setup Function for 
GAS sensor

Step 3	Read GAS Sensor Value

Step 4	If GAS sensor value is Greater than 
Threshold value than Print High

Step 5	If GAS sensor value is Less than 
Threshold value than Print Low

PROGRAMMING:
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HARDWARE

INSTRUCTIONS:

Connect GND pin of Gas sensor to GND on the Arduino UNO Board.

Connect Out pin of Gas sensor to A0 on the Arduino UNO Board.

Connect VCC pin of Gas sensor to 5V on the Arduino UNO Board.

Connect power supply to the Arduino board through USB from your laptop or desktop. 

Open Arduino IDE under Tools -> Board select Arduino Genuino UNO

Under Tools -> Serial Port select the Com # where the Arduino Genuino UNO is connected to
Write the above code on Arduino IDE

Upload to the Arduino UNO Board by clicking the upload button

Monitor the value of the gas sensor in the Serial Monitor.

HARDWARE CONNECTION

Arduino UNO Pin MQ Gas sensor pin

5V VCC

GND GND

Analog pin 0 (A0) Signal(A0)
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ULTRASONIC SENSOR 
INTRODUCTION
The sensor emits an ultrasound at 40,000 Hz which travels through the air and if there is an object 
or obstacle on its path It will bounce back to the module. Considering the travel time and the speed 
of the sound you can calculate the distance. In order to generate the ultrasound, you need to set the 
Trig on a High State for 10 µs. That will send out an 8-cycle sonic burst which will travel at the speed 
sound and it will be received in the Echo pin. The Echo pin will output the time in microseconds the 
sound wave travelled.

The HC-SR04 Ultrasonic Module has 4 pins, Ground, VCC, Trig and Echo. The Ground and the VCC 
pins of the module needs to be connected to the Ground and the 5 volts pins on the Arduino Board 
respectively and the trig and echo pins to any Digital I/O pin on the Arduino Board.

OBJECTIVE
During this activity, you will help students to achieve following objectives:

	y Understanding principle and operations of HCSR04 Sensor.

	y Design algorithm and flowchart to detect using HCSR04 sensor.

	y Programming HCSR04 sensor using Arduino API for Arduino/Genuino UNO.

	y Interfacing HCSR04 sensor with Arduino/Genuino UNO using digital pins.

APPLICATION
Robotics Barrier, Object distance measurement., Level detection, Public security, Parking detection.
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ALGORITHM FLOWCHART:

Step 1 Start

Step 2 Define trig pin and echo pin.

Step 3 Define duration and distance.

Step 4 Set trig as output pin 

Step 5 Set echo as Input pin

Step 6 Calculate duration and distance

Step 7 Print distance

Step 8 End

 

Calculate duration and 
distance 

START 

Define Trig, Echo, 
duration, Distance 

 

Set Trig pin as output and 
echo pin as input 

STOP 

Print distance 

PROGRAMMING:
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HARDWARE

INSTRUCTIONS:

Connect GND pin of HCSR04 to GND on the Arduino UNO Board. 

Connect trig pin of HCSR04 to d11 and echo pin to d12  on the Arduino UNO Board

Connect VCC pin of HCSR04 to 5V on the Arduino UNO Board.

Connect power supply to the Arduino board through USB from your laptop or desktop. 

Open Arduino IDE under Tools -> Board select Arduino Genuino UNO

Under Tools -> Serial Port select the Com # where the Arduino Genuino UNO is connected to
Write the above code on Arduino IDE

Upload to the Arduino UNO Board by clicking the upload button

Monitor the value of the HCSR04 in the Serial Monitor.

Arduino UNO Pin HCSR04 sensor pin

5V VCC

GND GND

D11 Trig

D12 Echo
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DHT 11 – TEMPERATURE & HUMIDITY 
SENSOR

INTRODUCTION
The DHT11 is a sensor for measuring temperature and humidity. The DHT11 is a commonly used 
temperature and humidity sensor. The sensor comes with a dedicated NTC to measure temperature 
and an 8-bit microcontroller to output the values of temperature and humidity as serial data. The 
sensor is also factory calibrated and hence easy to interface with other microcontrollers.

The sensor can measure temperature from 0°C to 50°C and humidity from 20% to 90% with an 
accuracy of ±1°C and ±1%. So if you are looking to measure in this range then this sensor might be 
the right choice for you.

OBJECTIVE
During this activity, you will help students to achieve following objectives:

	y Understanding principle and operations of DHT11 sensor.

	y Design algorithm and flowchart to determine temperature and humidity.

	y Programming DHT11 sensor using Arduino API for Arduino Genuino UNO.

	y Interfacing DHT11 sensor with Arduino Genuino UNO using digital pin D3.

APPLICATION
	y DHT11 would be useful include remote weather stations, home environment control systems, and 

agricultural/garden monitoring systems. 

	y It’s accurate enough for most projects that need to keep track of humidity and temperature 
readings.

	y HVAC, dehumidifier, testing and inspection equipment, consumer goods, automotive, automatic 
control, data loggers, weather stations, home appliances, humidity regulator, medical and other 
humidity  measurement and control
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ALGORITHM LIBRARY FLOWCHART: HOW TO INCLUDE

Step1 : Start

Step-2: Install the libraries	

Step-3: Define DHT11 pin

Step-4: Read signals from 
DHT11.

Step-5: Print Temp and 
Humidity

Step-6: End

 

Read signals from dht11 

START 

Install DHT 11Libraries 

 

Define DHT11 

STOP 

Print Temp and 
Humidity 

Download the DHT library 
from the link-

https://drive.google.com/file/0
B1paTI5fzcHodno5azFOSVVD
T0E/view?usp=sharing

Go to Sketch--> Include 
Library --> Add Zip File

Browse the ZIP file and 
include the library after 
including the library, close 
the Arduino IDE and open it 
again to include the library.

 

PROGRAMMING:
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HARDWARE

INSTRUCTIONS:

Connect GND pin of DHT11 to GND on the Arduino UNO Board. 

Connect data pin of DHT11 sensor to d3 on the Arduino UNO Board

Connect VCC pin of DHT11 sensor to 5V on the Arduino UNO Board.

Connect power supply to the Arduino board through USB from your laptop or desktop.

Open Arduino IDE under Tools -> Board select Arduino Genuino UNO

Under Tools -> Serial Port select the Com # where the Arduino Genuino UNO is connected to
Write the above code on Arduino IDE

Upload to the Arduino UNO Board by clicking the upload button

Monitor the value of the DHT11 sensor value in the Serial Monitor.

HARDWARE CONNECTION

Arduino UNO Pin DHT11 Pin

5V VCC

GND GND

Digital pin 3 Data pin of dht
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LDR MODULE
INTRODUCTION
LDR sensor module is used to detect the intensity of light. It is associated with both analog output 
pin and digital output pin labelled as AO and DO respectively on the board. When there is light, the 
resistance of LDR will become low according to the intensity of light. The greater the intensity of light, 
the lower the resistance of LDR. The sensor has a potentiometer knob that can be adjusted to change 
the sensitivity of LDR towards light. 

OBJECTIVE
During this activity, you will help students to achieve following objectives: 

	y Understanding principle and operations of LDR sensor.

	y Design algorithm and flowchart to sense light using LDR sensor.

	y Programming LDR sensor using Arduino API for Arduino

	y Interfacing LDR sensor with Arduino using analog pin A0.

LDR SENSOR APPLICATION
LDR commonly used to switch ON – OFF the circuit depending on the intensity of light.
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ALGORITHM FLOWCHART:

Step 1 Assign analog pin A0 to LDRPin 

Step 2 Define and initialize LDRValue to 0 I,e int 
LDRValue=0 

Step 3 Read LDRPin and store value in LDRValue 
variable 

Step 4 Print LDRValue on Serial monitor 

Step 5 If LDRValue is less than 10, print “Dark” 
on serial monitor 

Step 6 If LDRValue is less than 200, print “Dim” 
on serial monitor 

Step 7 If LDRValue is less than 500, print “Light” 
on serial monitor 

Step 8 If LDRValue is less than 800, print 
“Bright” on serial monitor 

Step 9 Else print “Very Bright” on serial monitor

 
START 

Assign analog pin A0 to LDRpin 

 

Define and Initialize LDRValue to 
0 i.e. int LDRValue=0 

STOP 

Read LDRPin and store value in 
LDRValue variable 

Print LDRValue in Serial monitor 

LDRValue<3
0? 

LDRValue<5
00? 

LDRValue<8
00? 

LDRValue<2
00? 

A 

A 

Very Bright 

Bright 

Dark 

Light 

Dim 

No 

Yes 

Yes 

Yes 

Yes 

No 

No 

No 

PROGRAMMING:
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HARDWARE

INSTRUCTIONS:

Connect GND pin of LDR sensor to GND on Arduino UNO

Connect Out pin of LDR sensor to A0 on the Arduino UNO 

Connect VCC pin of LDR sensor to 5V on the Arduino UNO

Connect power supply to the Arduino board through USB from your laptop or desktop.

Open Arduino IDE under Tools -> Board select Arduino Genuino UNO

Under Tools -> Serial Port select the Com # where the Arduino Genuino UNO is connected to
Write the above code on Arduino IDE

Upload to the Arduino UNO Board by clicking the upload button

Arduino pin PIR Sensor Pin

5V VCC (pin 1)

Analog pin  (A0) Signal (pin 2)

GND GND (pin 3)
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PIR SENSOR
INTRODUCTION
A passive infrared sensor (PIR sensor) is an electronic sensor that measures infrared light radiating 
from objects in its field of view. They are most often used in PIR-based motion detectors. 

PIR sensors detect general movement, but do not give information on who or what moved. The term 
passive refers to the fact that PIR devices do not radiate energy for detection purposes. They work 
entirely by detecting infrared radiation (radiant heat) emitted by or reflected from objects. 

 

OBJECTIVE
During this activity, you will help students to achieve following objectives: 

	y Understanding principle and operations of PIR sensor.

	y Design algorithm and flowchart to create motion detector using PIR Sensor.

	y Programming PIR Sensor using Arduino API for Arduino Uno.

	y Interfacing PIR sensor with Arduino Uno using digital pin

PIR SENSOR APPLICATION
PIR sensors commonly used in Burglar alarms, Automatically-activated lighting systems, Measuring 
the temperature of a remote object.
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ALGORITHM FLOWCHART:

Step 1   Assign Digital pin 2 to PIR Sensor as 
input

Step 2   Assign Digital Pin 3 for Buzzer/LED as  
output

Step 3   Read sensor value 

Step 4   If sensor value is “HIGH” then write the 
LED/Buzzer value as “HIGH”

Step 5   Wait for 1000ms

Step 6   Write the LED/Buzzer value as “LOW”

 

False 

True 

START 

Assign digital pin 2 for PIR 
sensor as Input 

Read the sensor Value 

Write LED/Buzzer value 
=Low 

Write LED/Buzzer 
Value=HIGH 

Assign digital Pin 3 for 
LED/Buzzer as Output 

If 
SensorValue=
=HIGH 

STOP 

Wait for 1000 

PROGRAMMING:
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HARDWARE

INSTRUCTIONS:

Connect the sensor and Buzzer/LED as shown in the hardware connection table.

Connect the power supply to Arduino through USB connected with Laptop or Desktop

Open Arduino IDE under Tools -> Board: Arduino / Geniuno Uno

Under Tools -> serial port: select the COM where Arduino is connected
Write the code in the Arduino IDE

Upload the code on Arduino Uno by clicking upload button

Check the program by bringing any object/hand near sensor to trigger the LED/Buzzer

Arduino pin PIR Sensor Pin

5V VCC (pin 1)

Digital Pin 2 Signal (pin 2)

GND GND (pin 3)

Arduino pin Buzzer/LED

GND Negative

Digital Pin 3 Positive
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SOUND SENSOR
INTRODUCTION
The sound sensor is one type of module used to notice the sound. Generally, this module is used to 
detect the intensity of sound. The applications of this module mainly include switch, security, as well 
as monitoring. The accuracy of this sensor can be changed for the ease of usage. This sensor employs 
a microphone to provide input to buffer, peak detector and an amplifier. This sensor notices a sound, 
& processes an o/p voltage signal to a microcontroller. After that, it executes required processing. 
This sensor is capable to determine noise levels within DB’s or decibels at 3 kHz-6 kHz frequencies 
approximately wherever the human ear is sensitive. In smartphones, there is an android application 
namely decibel meter used to measure the sound level. 

OBJECTIVE
During this activity, you will help students to achieve following objectives: 

	y To understand the working principle of a sound sensor.

	y Define and initialize setup for sound sensor and connect the LED.

	y Design algorithm and flowchart for the sound sensor and LED.

	y Programme the sound sensor and LED using Arduino IDE for Arduino UNO.

	y Interface the sound sensor and LED with Arduino using digital pins.
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ALGORITHM FLOWCHART:

Step 1: Assign digital pin to sound sensor as 
well as to LED.

Step 2: Define and initialize setup function for 
IR sensor.

Step 3: Read the sound sensor value.

Step 4: If SensorData is 1 then LED is ON

Step 5: Else the LED is OFF. 

 
START 

Assign digital pin-2 to Out 
of Sound sensor 

Read the sound sensor 
value 

LED is ON 

LED is OFF 

Assign digital pin 12 to LED 

If(SensorData
==1) 

STOP 

True 

False 

PROGRAMMING:
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HARDWARE

INSTRUCTIONS:

Connect GND pin of sound sensor to GND on the Arduino UNO Board. 

Connect Out pin of sound sensor to digital pin 2 on the Arduino UNO Board.

Connect VCC pin of sound sensor to 5V on the Arduino UNO Board.

Connect the led pin to digital pin 12 of Arduino UNO.

Connect power supply to the Arduino board through USB from your laptop or desktop. 

Open Arduino IDE under Tools -> Board select Arduino Genuino UNO

Under Tools -> Serial Port select the Com # where the Arduino Genuino UNO is connected to
Write the above code on Arduino IDE

Upload to the Arduino UNO Board by clicking the upload button

Monitor the change in value of the sound sensor and observe the LED.
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SOIL MOISTURE SENSOR
INTRODUCTION
Soil moisture sensor has two probes, and the resistance between the two probes is determined by 
the moisture in the soil. As shown in below figure, more the moisture, less is the resistance and vice- 
versa. This change in resistance can be measured by using multimeter. 

APPLICATION
Detecting the amount of moisture in the soil and managing irrigation systems.

OBJECTIVE
During this activity, you will help students to achieve following objectives: 

	y Understanding principle and operations of Soil Moisture sensor.

	y Design algorithm and flowchart to sense moisture of soil using Soil Moisture sensor.

	y Programming Soil Moisture sensor using Arduino API for Arduino Uno.

	y Interfacing Soil Moisture sensor with Arduino Uno using analog pin A0.



138

ALGORITHM FLOWCHART:

Step 1   Assign analog pin A0 to Moisture 
Sensor

Step 2   Define and initialize SensorValue to 0 
I.e int SensorValue=0

Step 3   Read SensorPin and store value in 
SensorValue variable

Step 4   if sensor value is equal to or greater 
than 500 then print “WET “

Step 5   if sensor value is equal to or less than 
200 then print “DRY”.

 

 
START 

Assign Analog pin A0 to 
Moisture sensor 

Read sensor value and store 
in SensorValue variable 

Print WET 

Print DRY 

Define and Initialize 
moisture sensor value to 0 

If 
SensorValue>=500 

STOP 

True 

False 

PROGRAMMING:
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HARDWARE

INSTRUCTIONS:

Connect GND pin of Soil Moisture sensor to GND on the Arduino board

Connect Out pin of Soil Moisture sensor to A0 on the Arduino board

Connect VCC pin of Soil Moisture sensor to 5V on the Arduino board

Connect LED (+) ve to Digital Pin 13 and LED (-) ve to GND to Arduino 

Connect power supply to the Arduino and USB to USB Client Port on the Arduino

Open Arduino IDE under Tools -> Board select Arduino Uno

Under Tools -> Serial Port select the Com # where the Arduino is connected to

Write the above code on Arduino IDE

Upload to the Arduino by clicking the upload button

Monitor the value of the soil moisture sensor in the Serial Monitor

Arduino pin Soil Moisture Sensor Pin

Negative VCC

GND GND

Analog pin 0 Signal
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WATER LEVEL SENSOR
INTRODUCTION
Water Level sensor works on the principle of conduction. When the sensor is immersed in water or 
any other conductive liquid, the resistance of the sensor changes. This in turn produces an analog 
voltage signal which is dependent on the level of water. For example, if level of the water is high, it 
measures low resistance. That resistor can be measured by using multimeter.

APPLICATION
Can be used in factories, commercial complexes, apartments, home etc. as automatic ON/OFF 
pumps.

OBJECTIVE
During this activity, you will help students to achieve following objectives: 

	y Understanding principle and operations of Water Level sensor.

	y Design algorithm and flowchart to sense the water level using Water Level sensor.

	y Programming Water Level sensor using Arduino IDE for Arduino Uno.

	y Interfacing Water Level sensor with Arduino Uno using analog pin A0.
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ALGORITHM FLOWCHART:

Step 1   Assign analog pin A0 to Water Level 
Sensor.

Step 2   Define and initialize SensorValue to 0, 
I.e. int SensorValue=0

Step 3   Read SensorPin and store value in 
SensorValue variable

Step 4   Print SensorValue on Serial monitor

 

PROGRAMMING:
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HARDWARE

INSTRUCTIONS:

Connect GND pin of Soil Moisture sensor to GND on the Arduino board

Connect Out pin of Soil Moisture sensor to A0 on the Arduino board

Connect VCC pin of Soil Moisture sensor to 5V on the Arduino board

Connect LED (+) ve to Digital Pin 13 and LED (-) ve to GND to Arduino 

Connect power supply to the Arduino and USB to USB Client Port on the Arduino

Open Arduino IDE under Tools -> Board select Arduino Uno

Under Tools -> Serial Port select the Com # where the Arduino is connected to

Write the above code on Arduino IDE

Upload to the Arduino by clicking the upload button

Monitor the value of the soil moisture sensor in the Serial Monitor

Arduino pin Water Level Sensor Pin

5V VCC(Red Wire)

GND GND(Black Wire)

Analog pin A0 Signal(Blue Wire)
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RAIN DROP SENSOR
INTRODUCTION
The raindrop sensor module is used for rain detection. It is also for measuring rainfall intensity. The 
module includes a rain board and a control board that are separate for more convenience. It has a 
power indicator LED and an adjustable sensitivity though a potentiometer.

APPLICATION
	y On windscreen of car to automatically start the wipers

	y On roof of houses and offices to take necessary action against rain

	y In Weather Station

OBJECTIVE
During this activity, you will help students to achieve following objectives:  

	y Understanding principle and operations of rain drop sensor.

	y Design algorithm and flowchart of rain drop sensor.

	y Programming rain drop sensor using Arduino API for Arduino Genuino UNO. 

	y Interfacing rain drop  sensor with Arduino Genuino UNO using analog pin A0.
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ALGORITHM FLOWCHART:

Step 1: Start.

Step 2: Assign analog pin A0 to A0 of sensor 
pin.

Step 2: Assign digital pin2 to D0 of sensor pin.

Step 3: Read Sensor value.

Step 4: Print the value.

Step 5: Stop.

 

 
START 

Analog A0 to Sensor A0 

 

Digital Pin#2 to D0 of 
Sensor 

STOP 

Print the values 

Read Sensor values 

PROGRAMMING:
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GLIMPSES
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